به دلیل آسیب‌پذیری OpenSSH هکرها می‌توانند حمله Brute-Force را پیاده‌سازی کنند.
تاریخ انتشار: ۰۳ مرداد ۱۳۹۴ - ۱۵:۵۹
کد خبر: ۱۴۱۴۲
آسیب‌پذیری جدیدی برای OpenSSH شناسایی‌شده است که می‌توان با استفاده از آن اقدام به پیاده‌سازی حمله Brute-Force کرد. سرورهایی که از نسخه آسیب‌پذیر OpenSSH استفاده می‌کنند، در معرض حمله Brute-Force قرار دارند و هکرها می‌توانند هزاران نام کاربری و رمز عبور را بر روی آن‌ها امتحان کنند. این آسیب‌پذیری با کد CVE-2015-5600 شناخته می‌شود.

OpenSSH یک نرم‌افزار به‌منظور رمزنگاری ترافیک داده کلاینت به سرور است تا مانع شنود اطلاعات و پیاده‌سازی حمله‌هایی مانند مردمیانی (Man in the Middle) شود. آخرین نسخه این نرم‌افزار یعنی 6.9 دارای آسیب‌پذیری است.

به‌طورمعمول OpenSSH تنها اجازه 3 تا 6 خطای نام کاربری و رمز عبور را می‌دهد و پس از عدم موفقیت ارتباط به‌طور خودکار قطع می‌شود. اما با استفاده از آسیب‌پذیری کشف‌شده می‌تواند از این محدودیت عبور کرد.

البته پس از عبور از این محدودیت، محدودیت بعدی ورود، یعنی حداکثر زمان ورود به سامانه است هنوز باقی است. به‌صورت پیش‌فرض کاربر فرصت دارد تا 2 دقیقه نام کاربری و رمز عبور صحیح را وارد کند، در غیر این صورت ارتباط قطع می‌شود. البته این دو دقیقه زیاد مشکل‌ساز نبوده و می‌توان دوباره یک ارتباط از نو ایجاد کرد. در همین دو دقیقه می‌توان 10000 رمز عبور را امتحان کرد.

در نسخه بعدی OpenSSH یعنی نسخه 7.0 این آسیب‌پذیری رفع خواهد شد. ولی تا آن زمان موارد زیر حتماً انجام شود:

پیاده‌سازی محدودیت برای دسترسی به SSH توسط فایروال
غیرفعال کردن احراز هویت رمز عبور برای حساب کاربری root
استفاده از IDS به‌منظور کاهش احتمال حمله Brute-Force
استفاده از رمز عبور قوی
استفاده از کلید رمزنگاری با حداقل طول 2048 بیت
کاهش زمان پیش‌فرض ورود به 20 تا 30 ثانیه
کنترل تعداد ورود ناموفق
برچسب اخبار:
برچسب ها: آسیب ، کلاینت
نظر شما :
نام:
ایمیل:
* نظر:
* کد امنیتی:
Chaptcha
حروفي را كه در تصوير مي‌بينيد عينا در فيلد مقابلش وارد كنيد